Engage BI - Rate limit issue
Incident Report for World of Tulo
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 15:19 CEST
Update
We are continuing to investigate this issue.
Posted Oct 02, 2024 - 15:06 CEST
Investigating
Some visitors are met with the message "Too Many Requests" and cannot use Engage BI, we are looking into this and will get back with more information as soon as possible.
Posted Oct 02, 2024 - 15:05 CEST
This incident affected: Tulo Engage (Engage BI).